Network controller or FlexibleLOM stopped working when an expansion board was added
Symptom
The network controller or FlexibleLOM stopped working when an expansion board was added to the server.
Cause
- The network controller or FlexibleLOM is not seated or connected properly.
- The network controller or FlexibleLOM is not supported by the OS or the server.
- Installation of the network controller or FlexibleLOM changes the server configuration.
- The network controller or FlexibleLOM drivers are out of date.
- The driver parameters do not match the configuration of the network controller.
Action
- Be sure no loose connections exist. For more information, see "Resolving loose connections."
- Be sure the server and operating system support the controller. For more information, see the operating system documentation or server documentation.
- Be sure the new expansion board has not changed the server configuration, requiring reinstallation of the network driver:
- Uninstall the network controller driver for the malfunctioning controller in the operating system.
- Restart the server and run the appropriate option in the UEFI System Utilities. Be sure the server recognizes the controller and that resources are available for the controller.
- Restart the server, and then reinstall the network driver.
- Be sure the correct drivers are installed. For more information, see the operating system documentation.
- Be sure that the driver parameters match the configuration of the network controller. For more information, see the operating system documentation.