Profile operations are not successful in HPE OneView

Symptom

Message indicates that the server is managed by another management system.

To prevent losing all allocated virtual IDs, perform the steps in this section before forcibly deleting the server profile.

Cause

The enclosure is no longer managed by HPE OneView.

Action
  1. Use REST APIs or Powershell to get the server profile.
    GET /rest/server-profiles
  2. Force delete the profile using the UI or REST APIs.
  3. Recreate the IDs using the User Specified option in the UI, or use REST APIs to create the server profile:
    1. Get the server profile.
      GET /rest/server-profiles
    2. Edit the server profile. Remove uri, serverHardwareTypeUri, enclosureGroupUri, enclosureUri, and enclosureBay
    3. Change the serverHardwareUri value to the server the profile is going to be associated to.
    4. Change serialNumberType from Virtual to UserDefined.
    5. In the connections property, change macType from Virtual to UserDefined.
    6. In the connections property, change wwpnType from Virtual to UserDefined
    7. In the connections property, if applicable change networkUri with the correct networks.
    8. Create the server profile.
      POST /rest/server-profiles