无法为目录服务添加服务器

症状

无法为目录服务配置服务器。

解决方案 1
原因

设备断开到目录服务的连接,但该连接已中断。

操作
  1. 验证目录服务主机的设置是否准确。
  2. 验证目录服务是否使用正确的端口。
  3. 验证用于通信的端口(默认端口为 636)是否未被任何防火墙阻止。
  4. Ping 主机名或 IP 地址,以确定目录服务主机是否联机。
  5. 确认设备网络正常运行。
  6. 如果设备托管在虚拟机上,则确定它正常运行并具有足够的资源。
解决方案 2
原因

在登录到目录服务服务器时,出现身份验证错误。

操作
  1. 验证登录名和密码是否正确。
  2. 重新获取并安装目录服务主机证书。
  3. 与目录服务提供商联系,以确保证书是准确的。
解决方案 3
原因

在配置目录服务时,使用的参数不正确。

操作
  1. 验证目录服务名称是否为唯一的,并且正确输入了该名称。不接受重复的名称。
  2. 验证目录类型是否正确。
  3. 确保基本 DN 字段以及用户命名属性 (OpenLDAP) 和组织单位字段正确无误。
  4. 验证身份验证目录服务管理员的凭据是否正确。
  5. 验证是否在目录服务中配置了组。