About unsupported firmware

When you add a resource to bring it under management, update the resource firmware to the minimum supported level. The appliance attempts to automatically update the firmware while the resource is being added to the appliance. If the update fails, an alert is generated.

NOTE:

Upload a supported SPP to the appliance firmware repository before updating device firmware. See http://www.hpe.com/servers/spp/download to obtain HPE OneView software updates and product-specific firmware bundles.

Uploading firmware bundles that do not contain the management firmware components

If you attempt to add a firmware bundle that does not contain the required firmware version and components, then the firmware bundle is uploaded with a warning message in the appliance firmware repository. The warning message displays the missing components in the firmware bundle. All the components with versions older than the minimum required versions are considered as missing.

Unsupported firmware for enclosures

When adding an enclosure, the appliance:

  • Generates an alert if:

    • the logical interconnect firmware for the interconnects is older than the required minimum version

      or
    • the interconnect firmware levels do not match.

    Update the logical interconnect firmware from the Logical Interconnects screen or REST APIs.

  • Updates the Onboard Administrator (OA) firmware automatically, if the version is older than the required minimum (must have a supported SPP installed on the appliance).

  • Updates the iLO firmware automatically, if the version is older than the required minimum (must have a supported SPP installed on the appliance).

Unsupported firmware for logical enclosures

When adding a logical enclosure, the appliance:

  • Generates an alert if the actual firmware versions for one or more components do not match the required minimum. Even if you do not specify a baseline, SPP and iLO firmware update automatically, if the version is older than the required minimum (must have a supported SPP installed on the appliance). Select the firmware baseline from the Logical Enclosures screen or REST APIs.

Unsupported firmware for server profiles

You are prevented from applying server profiles if the associated iLO firmware is a version older than the minimum supported version, and instead, are directed to the Server Hardware screen to update iLO firmware.

Unsupported firmware for interconnects

If you attempt to add an interconnect with firmware that is older than the minimum supported version, then an alert is generated. Update the logical interconnect firmware from the Logical Interconnects screen or REST APIs. The Firmware panel of the Logical Interconnects screen displays the installed version of firmware and the firmware baseline for each interconnect.