无法添加目录服务

症状

您无法将目录服务添加到设备中。

解决方案 1
原因

外部问题导致到目录服务器主机的连接中断。

操作
  1. 以基础架构管理员身份登录
  2. 验证目录服务主机的设置是否准确。
  3. 在本地针对目录服务器的 IP 地址或主机名 Ping 主机名或 IP 地址,以确定目录服务器是否联机。
  4. 验证与目录服务的 LDAP 通信端口是否为端口 636。
  5. 验证用于通信的端口(默认端口为 636)是否未被任何防火墙阻止。
  6. 确认设备网络正常运行。
  7. 确定设备是否正常工作并具有足够的资源。
解决方案 2
原因

由于证书已过期,目录服务器主机拒绝对设备进行身份验证。

操作
  1. 以基础架构管理员身份登录
  2. 验证登录名和密码是否正确。
  3. 与目录服务提供商联系,以确保证书是准确的。
  4. 重新获取并安装目录服务主机证书。
解决方案 3
原因

证书不是有效的 x509 格式。

操作
  1. 以基础架构管理员身份登录
  2. 请更正配置,然后重试。
  3. 如有必要,请重新获取并安装目录服务主机证书。
  4. 与目录服务提供商联系,以确保证书是准确的。
解决方案 4
原因

证书不包含 x509v3 密钥用法扩展。

操作
  1. 以基础架构管理员身份登录
  2. 确保证书包含密钥用法扩展。
  3. 如有必要,请重新获取并安装目录服务主机证书。
解决方案 5
原因

由于凭据无效,目录服务器主机无法对设备进行身份验证。

操作
  1. 以基础架构管理员身份登录
  2. 验证登录名和密码是否正确。
  3. 验证搜索上下文信息是否准确,您可能会尝试访问一个不同的帐户或组。
  4. 重新获取并安装目录服务主机证书。
  5. 与目录服务提供商联系,以确保证书是准确的。