Alert email notifications not received after update

Symptom

Alert email notifications are no longer received for some resources after update.

Cause

The email notification filter includes a scope component and some resources are no longer assigned to the scope. This can occur if resources are removed by a user from the scope or if the resources are in categories for which scope restrictions are newly enabled. Because resources in categories for which scope restrictions are not enabled are automatically included in all scopes, the addition of scope restrictions for a resource category causes the resources to be removed implicitly from all scopes on update.

Action
  1. Check the resource categories for which scope restrictions are enabled.
  2. Ensure the desired resources in these categories are assigned to the scopes used in email notification filters.
  3. Designate associated resource categories in email notification filters that include a scope component, so as not to rely on the implicit inclusion of resources for which scope restrictions are not enabled.