CA署名付きクライアント証明書を使用してSCMBサーバーに接続できない

症状

CA署名付きクライアント証明書を作成した後でも、SCMBサーバーへの接続を確立できない。

解決方法 1
原因

クライアント証明書は、アプライアンスによって信頼されている認証機関(CA)によって署名されていません。

アクション
  1. openssl verify -verbose -CAfile ca.pem cert.pemコマンドを使用して、クライアント証明書に署名したCAを確認します。
  2. 設定>セキュリティにアクセスして、信頼済みCAのリストをチェックすることで、一覧表示されているCAルートおよび中間証明書がアプライアンスによって信頼されていることを確認します。
  3. クライアント証明書への署名に使用したCAが存在しない場合、そのCAをHPE OneViewに追加します。
解決方法 2
原因

SCMBサーバー証明書への署名に使用したルートCA証明書または中間CA証明書が、クライアントが使用するCA証明書ファイルに含まれていない。

アクション
クライアントが使用するCA証明書ファイルに、SCMBサーバー証明書に署名したルート証明書および中間CA証明書が含まれていることを確認します。
解決方法 3
原因

クライアント証明書への署名に使用した中間CA証明書が、クライアントが使用するCA証明書ファイルに含まれていない。

アクション
クライアントが使用するCA証明書ファイルに、クライアント証明書に署名した中間CA証明書が含まれていることを確認します。
解決方法 4
原因

クライアント証明書が、rabbitmq_readonly以外の共通名を使用する。

アクション
  1. 証明書の属性を表示するには、openssl x509 -noout -text -in cert.pemコマンドを使用します。
  2. クライアント証明書にrabbitmq_readonly以外の共通名が使用されている場合、新しいクライアント証明書を作成します。SCMBサーバーはこのユーザーからの接続を受け入れるように構成されているため、クライアント証明書の共通名はrabbitmq_readonlyに設定する必要があります。
解決方法 5
原因

CAチェーンに、ルートCAを含めず9を超える中間証明書が含まれている(ルートCA >中間1 >中間2 > ... >中間8 >中間9)。

アクション
HPE OneViewがサポートできるのは、最大9レベルのCAチェーンだけです。9より少ないレベルが含まれるように、CAチェーンの最小レベルを切り取ります。