Volume not available to server hardware in HPE OneView

Symptom

The volume is not accessible on the server.

Solution 1
Cause

A possible cause of a volume not being accessible on the server is that the SAN zone is improperly configured or missing.

Action
  1. Re-enable the attachment (Managed SAN case):
    1. From the main menu, select SERVERS > Server Profiles.
    2. In the master pane, select a server profile and select Actions > Edit.
    3. Locate the port you want to enable and select Enable.
    4. Click OK.
  2. Create or configure the zone using the SAN management software (no managed SAN).
    1. Click OK.
    2. See the SAN manager documentation.
  3. Using managed SANs
    1. Verify that the SAN manager and SAN is associated with the network.
    2. Verify that Automate zoning is enabled.
  4. Automated zoning is not enabled on the SAN
    1. Verify that the zone has been manually configured.
    2. See the SAN manager documentation.
Solution 2
Cause

A possible cause of a volume not being accessible on the server is that the Server initiators are not logged into the fabric because the interconnect port is disabled.

Action
  1. Enable the interconnect port on the appliance
    1. From the main menu, select Interconnects.
    2. In the master pane, select an interconnect and select Actions > Edit.
    3. Locate the port you want to enable and select Enable.
    4. Click OK.
  2. You can also use the REST API to complete this task.

    REST API: /rest/interconnects/{id}/ports

    See the HPE OneView REST API Reference for more information.

  3. Re-configure the logical interconnect group
    1. From the main menu, select NETWORKING > Logical Interconnect Groups.
    2. In the master pane, select a logical interconnect group and select Actions > Edit.
    3. Edit the uplink sets to connect the networks with the desired interconnect ports.
    4. Click OK.
    5. Verify that the logical interconnect group link comes online.
    6. From the main menu, select Logical Interconnects.
    7. In the master pane, select a logical interconnect and select Actions > Update from group.
  4. You can also use the REST API to complete this task.

    REST API: /rest/logical-interconnect-groups/{id} and /rest/logical-interconnects/{id}/compliance

    See the HPE OneView REST API Reference for more information.

  5. Verify the physical cabling is configured as intended.
Solution 3
Cause

A possible cause of a volume not being accessible on the server is that the connection has not been defined in the server profile.

Action
  1. Add a connection to a network in the server profile. From the main menu, select SERVERS > Server Profiles.
  2. In the master pane, select a server profile and select Actions > Edit.
  3. Under Connections click Add Connection.
  4. For Device type select Fibre Channel over Ethernet.
  5. For Network select a network that is connected to the storage system and click Add.
  6. Click OK.