ディレクトリサービスを追加できない

症状

ディレクトリサービスをアプライアンスに追加することはできません。

解決方法 1
原因

外部的な問題により、ディレクトリサーバーのホストが切断されました。

アクション
  1. インフラストラクチャ管理者としてログインします。
  2. ディレクトリサービスホストの設定が正確であることを確認します。
  3. ディレクトリサーバーのIPアドレスまたはホスト名に対してローカルでホスト名またはIPアドレスのPingを実行して、オンラインかどうかを確認します。
  4. ディレクトリサービスとのLDAP通信用のポートがSSLポート(デフォルトは636)またはグローバルカタログSSLポート(デフォルトは3269)であることを確認します。
  5. 通信に使用しているポート(デフォルトポート636または3269)がファイアウォールによってブロックされていないことを確認します。

    HPE OneViewで必要なポートを参照してください。

  6. アプライアンスネットワークが正しく動作していることを確認します。
  7. アプライアンスが適切に機能していることと、十分なリソースがあることを確認します。
解決方法 2
原因

証明書の期限が切れているので、ディレクトリサーバーのホストがアプライアンスの認証を拒否しています。

アクション
  1. インフラストラクチャ管理者としてログインします。
  2. ログイン名とパスワードが正確であることを確認します。
  3. ディレクトリサービスプロバイダーに問い合わせて、認証情報が正確であることを確認します。
  4. ディレクトリサービスホスト証明書を再取得し、インストールします。
解決方法 3
原因

証明書が有効なx509のフォーマットではありません。

アクション
  1. インフラストラクチャ管理者としてログインします。
  2. 必要に応じて、ディレクトリサービスホスト証明書を再取得し、インストールします。
  3. ディレクトリサービスプロバイダーに問い合わせて、認証情報が正確であることを確認します。
解決方法 4
原因

証明書にx509v3 key usage extensionが含まれていません。

アクション
  1. インフラストラクチャ管理者としてログインします。
  2. 証明書にkey usage extensionが含まれていることを確認します。
  3. 必要に応じて、ディレクトリサービスホスト証明書を再取得し、インストールします。
解決方法 5
原因

認証情報が有効ではないため、ディレクトリサーバーのホストはアプライアンスを認証できません。

アクション
  1. インフラストラクチャ管理者としてログインします。
  2. ログイン名とパスワードが正確であることを確認します。
  3. 検索コンテキスト情報が正確であることを確認します。別のアカウントまたはグループにアクセスしようとしている可能性があります。
  4. ディレクトリサービスホスト証明書を再取得し、インストールします。
  5. ディレクトリサービスプロバイダーに問い合わせて、認証情報が正確であることを確認します。
解決方法 6
原因

ディレクトリサービスの構成時に、正しくないパラメーターが使用されました。

アクション
  1. ディレクトリサービスの名前が一意であり正しく入力されていることを確認します。重複する名前は使用できません。
  2. ディレクトリの種類が正しいことを確認します。
  3. ベースDNフィールドと、OpenLDAPの場合はユーザーネーミング属性フィールド、および組織ユニットフィールドが正しいことを確認してください。
  4. 認証ディレクトリサービス管理者の認証情報が正しいことを確認します。
  5. グループがディレクトリサービスに構成されていることを確認します。