HPE OneViewのサーバーハードウェアでボリュームを利用できない

症状

サーバーでボリュームにアクセスできない。

解決方法 1
原因

SANゾーンが正しく構成されていない、または存在しないことが、サーバーでボリュームにアクセスできない原因として考えられます。

アクション
  1. アタッチメントを再び有効にする(管理対象SANの場合):
    1. メインメニューからサーバー > サーバープロファイルの順に選択します。
    2. マスターウィンドウで、サーバープロファイルを選択し、アクション > 編集の順に選択します。
    3. 有効にするポートを見つけ、有効を選択します。
    4. OKをクリックします。
  2. SAN管理ソフトウェアを使用してゾーンを作成または構成します(管理対象SANなし)。
    1. OKをクリックします。
    2. SANマネージャードキュメントを参照してください。
  3. 管理対象SANを使用する場合
    1. SANマネージャーとSANがネットワークに関連付けられていることを確認します。
    2. 自動ゾーニングが有効になっていることを確認します。
  4. SANの自動ゾーニングが有効になっていない
    1. ゾーンが手動で構成されていることを確認します。
    2. SANマネージャードキュメントを参照してください。
解決方法 2
原因

インターコネクトポートが無効になっているためにサーバーイニシエーターがファブリックにログインしていないことが、サーバーでボリュームにアクセスできない原因として考えられます。

アクション
  1. アプライアンスでインターコネクトポートを有効にする
    1. メインメニューから、インターコネクトを選択します。
    2. マスターウィンドウで、インターコネクトを選択し、アクション > 編集の順に選択します
    3. 有効にするポートを見つけ、有効を選択します。
    4. OKをクリックします。
  2. このタスクを完了するのにREST APIを使用することもできます。

    REST API: /rest/interconnects/{id}/ports

    詳しくは、HPE OneView REST APIリファレンスを参照してください。

  3. 論理インターコネクトグループを再構成してください。
    1. メインメニューから、ネットワーク > 論理インターコネクトグループの順に選択します。
    2. マスターウィンドウで、論理インターコネクトグループを選択し、アクション > 編集の順に選択します。
    3. ネットワークが希望するインターコネクトポートと接続するようにアップリンクセットを編集します。
    4. OKをクリックします。
    5. 論理グループインターコネクトリンクがオンラインに復帰することを確認します。
    6. メインメニューから、論理インターコネクトを選択します。
    7. マスターウィンドウで論理インターコネクトを選択し、アクション > グループからアップデートの順に選択します。
  4. このタスクを完了するのにREST APIを使用することもできます。

    REST API:/rest/logical-interconnect-groups/{id}および/rest/logical-interconnects/{id}/compliance

    詳しくは、HPE OneView REST APIリファレンスを参照してください。

  5. 物理配線が意図したとおりに構成されていることを確認します。
解決方法 3
原因

接続がサーバープロファイルで定義されていないことが、サーバーでボリュームにアクセスできない原因として考えられます。

アクション
  1. サーバープロファイルでネットワークに接続を追加します。メインメニューからサーバー > サーバープロファイルの順に選択します。
  2. マスターウィンドウで、サーバープロファイルを選択し、アクション > 編集の順に選択します。
  3. 接続で、接続の追加をクリックします。
  4. デバイスタイプで、Fibre Channel over Ethernetを選択します。
  5. ネットワークで、ストレージシステムに接続されているネットワークを選択し、追加をクリックします。
  6. OKをクリックします。