HPE Smart Array S100i SR Gen10 drives are not found when RAID mode is disabled

Symptom

The HPE Smart Array S100i SR Gen10 drives are not found when RAID mode is disabled.

Cause

When an HPE Smart Array S100i SR Gen10 is enabled on a server and RAID mode is disabled in the UEFI System Utilities, then the drives are listed as AHCI drives or HPE H220i drives and the RAID controller is not found in POST or device manager. When RAID mode is enabled, the drives appear as HPE Smart Array S100i SR Gen10 drives.

Action
  1. Reboot the server.
  2. Access UEFI System Utilities by pressing F9 (System Utilities) during POST.
  3. Select System Configuration > BIOS/Platform Configuration (RBSU) > Storage Options > SATA Controller Options > Embedded SATA Configuration > Smart Array SW RAID Support and press the Enter key.
  4. In the SATA Controller Options screen, for the Embedded SATA configuration option, select Smart Array SW RAID Support from the drop-down menu and click OK.

    If you see the warning Important: Smart Array SW RAID is not supported when the Boot Mode is configured in Legacy BIOS Mode, click OK.

  5. Press F12: Save and Exit.
  6. To save changes, click Yes-Save Changes.
  7. Click Reboot.