Back to Top
HPE Servers Support & OS Certification Matrices
Canonical Ubuntu
Welcome to HPE's interactive Canonical Ubuntu Support and Certification webpage for HPE Servers.

Just click on the server to obtain driver downloads, certification and support information.

HPE is committed to supporting all customers that install the supported LTS versions of Ubuntu and latest security releases for Canonical.

Click on the product to obtain product information, downloads, certifications, and documentation.

HPE and Canonical Support

HPE Supported & OS Partner Certified/Logo - HPE server qualifies for an Ubuntu Advantage support contract that can be purchased from HPE Pointnext or Canonical for Ubuntu Server support on certified HPE Servers.

Ubuntu Releases

Canonical has committed to scheduled Ubuntu releases on a predictable six-month basis. Every fourth release, issued on a two-year basis, receives long-term support (LTS). LTS releases are typically used for commercial or large-scale deployments. Interim OS releases will not be officially certified by Canonical.

Please Note:

HPE will only certify and support LTS versions. Interim OS versions are not supported. Minimums versions for each supported Major LTS OS are listed below. Subsequent minor version releases for a listed Major version minimum release are also supported.

Ubuntu is Supported and Certified with in-distro drivers only. All model options and configurations are not necessarily supported. Please contact your HPE representative for more information.

View the Ubuntu Minimum Operating System Requirements Matrix

HPE Alletra
Product Minimum Required Ubuntu Version Installation Notes
Alletra 4110 22.04 LTS
Alletra 4120 22.04 LTS
Apollo
Product Minimum Required Ubuntu Version Installation Notes
XL170r Gen10 (Apollo 2000) 18.04 LTS
20.04 LTS
XL190r Gen10 (Apollo 2000) 18.04 LTS
20.04 LTS
XL220n Gen10 Plus (Apollo 2000) 20.04 LTS1
22.04 LTS
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
XL225n Gen10 Plus(Apollo 2000) 20.04 LTS1
22.04 LTS
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
XL270d Gen10 (Apollo 6500) 18.04 LTS
20.04 LTS
XL290n Gen10 Plus (Apollo 2000) 20.04 LTS1
22.04 LTS
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
XL420 Gen10 (Apollo 4200) 18.04 LTS
20.04 LTS
22.04 LTS
XL420 Gen10 Plus (Apollo 4200) 20.04 LTS1
22.04 LTS
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
XL645d Gen10 Plus (Apollo 6500) 20.04 LTS1
22.04 LTS
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
XL675d Gen10 Plus (Apollo 6500) 20.04 LTS1
22.04 LTS
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
Cray
Product Minimum Required Ubuntu Version Installation Notes
XD225v (XD2000) 22.04 LTS1 Notes
1AMD EPYC™ 9xx4 Series Processor Family requires a minimum of 22.04 LTS (5.15.0)
XD295v (XD2000) 22.04 LTS1 Notes
1AMD EPYC™ 9xx4 Series Processor Family requires a minimum of 22.04 LTS (5.15.0)
XD665 22.04 LTS
XD670 22.04 LTS
DL
Product Minimum Required Ubuntu Version Installation Notes
DL20 Gen10 Plus 22.04 LTS (5.15)1 Notes
1Intel Xeon E-2300 Processor Family requires a minimum of 22.04 LTS (5.15)
DL180 Gen10 18.04 LTS Notes
1st Generation Intel® Xeon® Scalable Processors 16.04.3 HWE (4.10)
DL320 Gen11 20.04.5 LTS (5.15.0)1
22.04 LTS (5.15.0)1
Notes
14th Generation Intel® Xeon® Scalable Processors
DL325 Gen10 Plus 20.04 LTS1
22.04 LTS
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
DL325 Gen10 Plus v2 20.04 LTS (5.4.0)1
22.04 LTS (5.15.0)1
Notes
1AMD EPYC™ 7xx3 Series Processor Family requires a minimum of 22.04 LTS (5.15.0)
DL325 Gen11 20.04 LTS1
22.04 LTS
Notes
1AMD EPYC™ 9xx4 Series Processor Family requires a minimum of 20.04.5 (5.15.0)
DL345 Gen10 Plus 20.04 LTS (5.4.0)1
22.04 LTS (5.15.0)1
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
DL345 Gen11 20.04.5 LTS (5.15.0)1
22.04 LTS (5.15.0)
Notes
1AMD EPYC™ 9xx4 Series Processor Family requires a minimum of 20.04.5(5.15.0)
DL360 Gen10 18.04 LTS
20.04 LTS
Notes
1st Generation Intel® Xeon® Scalable Processors 16.04.3 HWE (4.10)
DL360 Gen10 Plus 20.04 LTS (5.4.0)1
22.04 LTS (5.15.0)1
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
DL360 Gen11 20.04.5 LTS (5.15.0)1
22.04 LTS (5.15.0)
Notes
14th Generation Intel® Xeon® Scalable Processors require a minimum of 20.04.5 LTS (5.15.0)
DL365 Gen10 Plus 20.04 LTS (5.4.0)1
22.04 LTS (5.15.0)1
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
DL365 Gen11 20.04.5 LTS (5.15.0)1
22.04 LTS (5.15.0)1
Notes
1AMD EPYC™ 9xx4 Series Processor Family requires a minimum of 20.04.5(5.15.0)
DL380 Gen10 18.04 LTS
20.04 LTS
Notes
1st Generation Intel® Xeon® Scalable Processors 16.04.3 HWE (4.10)
DL380 Gen10 Plus 18.04.6 (HWE 5.4)1,2
20.04 LTS (5.4.0)1,2
22.04 LTS (5.15.0)1
Notes
13rd Generation Intel® Xeon® Scalable Processors require a minimum of 18.04.6(5.4)
2Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
DL380 Gen11 20.04.5 LTS (5.15.0)1
22.04 LTS (5.15.0)
Notes
14th Generation Intel® Xeon® Scalable Processors require a minimum of 20.04.5 LTS (5.15.0)
DL380a Gen11 20.04.5 LTS (5.15.0)1
22.04 LTS (5.15.0)
Notes
14th Generation Intel® Xeon® Scalable Processors require a minimum of 20.04.5 LTS (5.15.0)
DL385 Gen10 Plus 18.04 LTS (4.15.0)1
20.04 LTS (5.4.0)1
22.04 LTS (5.15.0)1
Notes
1Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
DL385 Gen10 Plus v2 20.04 LTS (5.4.0)1,2
22.04 LTS (5.15.0)
Notes
1AMD EPYC™ 7xx3 Series Processor Family requires a minimum of 20.04 LTS (5.4.0) 2Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 and Intel E810-XXVDA2 Ethernet 10/25Gb 2-port SFP28 OCP3 network adapters require Ubuntu 20.04.3(5.4.0.81) or later.
DL385 Gen11 20.04.5 LTS (5.15.0)1
22.04 LTS (5.15.0)
Notes
1AMD EPYC™ 9xx4 Series Processor Family requires a minimum of 20.04.5(5.15.0)
DL560 Gen10 18.04 LTS
20.04 LTS
Notes
1st Generation Intel® Xeon® Scalable Processors 16.04.3 HWE (4.10)
DL560 Gen11 20.04.5 LTS (5.15.0)1
22.04 LTS (5.15.0)
Notes
14th Generation Intel® Xeon® Scalable Processors require a minimum of 20.04.5 LTS (5.15.0)
Edgeline
Product Minimum Required Ubuntu Version Installation Notes
e920 Server Blade (EL8000) 22.04 LTS
e920d Server Blade (EL8000) 22.04 LTS
e920t Server Blade (EL8000t) 22.04 LTS
20.04 LTS
e910t Server Blade 20.04 LTS
m750 Server Blade 20.04 LTS
m510 Server Cartridge 18.0 LTS
m710x Server Cartridge 18.0 LTS
ML & MicroServer
Product Minimum Required Ubuntu Version Installation Notes
MicroServer Gen10 Plus v2 22.04 LTS
ML30 Gen10 Plus 22.04 LTS
ML110 Gen10 18.04 LTS1 Notes
11st Generation and 2nd Generation Intel Xeon® Scalable Processors require a minimum of 18.04 LTS (4.15.0)
ML110 Gen11 22.04 LTS
ML350 Gen11 22.04 LTS
RL
Product Minimum Required Ubuntu Version Installation Notes
RL300 Gen11 20.04 LTS1
22.05 LTS
Notes
1Ampere® Altra® & Altra® Max processors require a mimimum of 20.04 LTS (5.15.0)
Synergy
Product Minimum Required Ubuntu Version Installation Notes
480 Gen10 20.04 LTS
22.04 LTS
480 Gen10 Plus 20.04 LTS
22.04 LTS
480 Gen11 22.04 LTS
660 Gen10 20.04 LTS
22.04 LTS