The iLO certificate is not yet valid

Symptom

Unable to establish trusted communication with the server. The iLO certificate is not yet valid.

This alert was updated in HPE OneView 4.1.

ID: server-hardware.Certificate.psrm.trustFailure.sslnotyetvalid

Severity: Critical

Health Category: Operational

Resource URI: /rest/server-hardware/{UUID}

Cause

The iLO certificate is not valid.

Action
  1. Verify that both the HPE OneView appliance and iLO have the correct system date and time configured.
  2. Verify that the iLO has a valid certificate.
  3. Do one of the following:
    • If iLO has a CA signed certificate, verify that the root certificate and the appropriate intermediate certificates are present in the HPE OneView trust store.

    • If a new iLO self-signed certificate was generated to correct the issue, add this certificate into the HPE OneView trust store.

  4. Refresh the server, and then retry the operation.
  5. Use the link provided to add certificates to the HPE OneView trust store.