Drive is not detected

Symptom

The CD-ROM or DVD drive is not detected.

Cause
  • The CD-ROM or DVD drive is not cabled properly.

  • The CD-ROM or DVD drive cables are not connected properly.

  • The CD-ROM or DVD drive cable is not working.

  • The driver is not correct or up-to-date.

Action
  1. Verify that no loose connections exist.

    For more information, see Loose connections.

  2. Verify that the power-SATA Y-cable is properly connected to the optical drive.

    Verify that one end of the power-SATA Y-cable is connected to the optical drive, and verify that the split ends of the Y-cable are connected to the system board and the power supply.

  3. Verify that the cables are connected according to the instructions found in the documentation for the CD‑ROM or DVD drive and the server.

    For more information, see the CD-ROM or DVD drive documentation, or see the server documentation in the Hewlett Packard Enterprise Information Library.

  4. Verify that the cables are working properly.

    To verify, replace the cable with a known functioning cable. If the drive displays, then replace the original cable.

  5. Verify that the correct driver is installed and current.