PCIe cards in the PCIe expansion module are not found or available in the OS

Symptom
  • PCIe cards in the PCIe expansion module are not found or are not available in the OS.

  • The iLO Device Inventory shows PCIe slots as empty even when the PCIe slot is populated.

  • The expander LED is not illuminated.

  • The iLO Device Inventory shows mezzanine connector 1 empty.

  • HPE OneView reports that the compute module hardware cannot be discovered.

Cause
  • The mezzanine pass-through is not installed or is improperly seated on mezzanine connector 1.
  • The PCIe card is not properly seated in the PCIe expansion module.

Action
  1. Verify that the mezzanine pass-through card is installed on mezzanine connector 1.
  2. If the mezzanine pass-through card is installed on mezzanine connector 1, reseat the mezzanine pass-through card.
  3. Remove the PCIe riser cage from the PCIe expansion module.
  4. Remove the PCIe card from the PCIe cage.
  5. Reinstall the PCIe card into the PCIe riser cage.
  6. Reinstall the PCIe riser cage into the PCIe expansion module and verify that all thumbscrews are engaged fully.
    For compute module-specific information, see the product user guide on the Hewlett Packard Enterprise Information Library.